• Заказать настройку сервера или защиту от ddos

    Телеграм @kxkwork

Ставим(обновляем) маську (mysql) 5.7.* на KVM Debian-8-x86_64-minimal

В общем по заданию клиента нужно на Весте с Debian-8-x86_64-minimal обновить mysql 5.5 до 5.7 решил я проделать этот трюк

Ставим пакетик:

  • wget http://dev.mysql.com/get/mysql-apt-config_0.7.3-1_all.deb
  • dpkg -i mysql-apt-config_0.7.3-1_all.deb
  • Выбираем сервер, версию и жмём Ok и Ok
  • Ставим(обновляем) маську (mysql) 5.7.* на KVM  Debian-8-x86_64-minimal

Примечание:

Если на команду:

dpkg -i mysql-apt-config_0.7.3-1_all.deb

Вы получаете:

Selecting previously unselected package mysql-apt-config.
dpkg: regarding mysql-apt-config_0.7.3-1_all.deb containing mysql-apt-config, pre-dependency problem:
mysql-apt-config pre-depends on lsb-release
lsb-release is not installed.

То делаем:

apt-get install lsb-release  и повторяем

dpkg -i mysql-apt-config_0.7.3-1_all.deb

 

Апдейтим систему:

apt-get update

Впиливаем ключ

apt-key adv --keyserver pgp.mit.edu --recv-keys A4A9406876FCBD3C456770C88C718D3B5072E1F5

или так

apt-key adv --keyserver hkp://pgp.mit.edu:80 --recv-keys 5072E1F5

Собственно ставим:

apt-get install mysql-server -y

Апгрейдим таблички:

mysql_upgrade

Рестартим базку:

service mysql restart

Накатываем патч:

curl -O -k https://raw.githubusercontent.com/skurudo/phpmyadmin-fixer/master/pma.sh && chmod +x pma.sh && ./pma.sh

Всё, чудо сделано:)

 

 

 

 

Закладка Постоянная ссылка.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *